Catalina upgrade
Catalina upgrade
July 15, 2019 02:17PM
I have just upgraded my MacBook from Mojave OS to Catalina OS and have lost the use of Polar Navy, is there a new download I can install please?

Regards Alun
Re: Catalina upgrade
July 23, 2019 02:59PM
There is not a new version at this time. What issue are you seeing with the updated OS?

--
Polar Navy Support
Re: Catalina upgrade
July 24, 2019 05:38AM
When I open the App I get the message below:-

“PolarView” needs to be updated.
The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information.

I tried downloading a new copy and it opens up as map without charts but won't let me go any further with it unless I open a new account. I enter the account details I use to get on to this page but it won't accept them

Regards Alun
Re: Catalina upgrade
July 24, 2019 01:33PM
It sounds like you may have been using version 2.0 of PolarView. Version 2.0 has been discontinued a number of years ago. It does not include a 64 bit binary and as such will not run on MacOS Catalina, which no longer supports 32 bit applications.

PolarView 3.0 includes 64-bit MacOS binary. You will need to upgrade to current version of PolarView to use it with MacOS Catalina.

--
Polar Navy Support
Re: Catalina upgrade
July 24, 2019 02:03PM
I thought that may be the case which was why I downloaded the app again. The problem I have now is it opens up as map without charts but won't let me go any further as it asks I open a new account. I enter the account details I used to get on to this page but it won't accept them. What details should I enter please/
Re: Catalina upgrade
July 25, 2019 01:05AM
Polar Navy account is distinct from the support page account.

A Polar Navy account has been created for all users who have previously purchased PolarView NS activation code for version 2.0. The account was created using an email address from the original order. The account needs to be activated before use.

To activate your account, follow this link: [www.polarnavy.com] and select "Missing activation email" option.

For additional information on how to proceed please see this article: [support.polarnavy.com]

--
Polar Navy Support
Re: Catalina upgrade
July 25, 2019 07:11AM
I've tried that and it say "Error account already activated"

Alun
Re: Catalina upgrade
July 25, 2019 07:21AM
It seems I have the correct email address but no record of a password to go with it. I have the old activation codes which I assume are all out of date, but even if they were in date I couldn't get to the place to input one as I can't get past the page requiring my password. The only password I have that works seems to be for the support page account.

Alun
Re: Catalina upgrade
July 25, 2019 08:12AM
I managed to reset the password following your link and then gained access to my account, but when I try to login I get the message "your subscription to this service has expired". It was still working on the previous version and all I have done is upgrade to a later version, surely it should still work in that version? I wouldn't expect to lose a subscription simply by updating would I?

Alun
Re: Catalina upgrade
July 25, 2019 02:48PM
The licensing for version 3.0 has changed in 2016.
Please see this article for additional information: [support.polarnavy.com]

--
Polar Navy Support
Re: Catalina upgrade
July 25, 2019 04:51PM
Does this mean I need to buy a new subscription or does the paragraph below mean that I should already have an activation code?

"INFOUsers who have previously purchased PolarView NS activation code - an account has been created for you already, using an email address that was used for the original order. To activate this account, from the login page follow link for login and password help (or follow directly from here: [www.polarnavy.com]) and select "Missing activation email" option, to activate account and set a new password.
Re: Catalina upgrade
July 26, 2019 08:55AM
PolarView version 2.0 can be used with your existing activation code, if you have activations available. However, PolarView 2.0 is no longer supported and cannot be used on 64bit MacOS versions.

PolarView 3.0 supports 64 bit MacOS. To use PolarView 3.0 you would need to purchase an appropriate subscription.

--
Polar Navy Support
Re: Catalina upgrade
July 26, 2019 02:27PM
OK problem solved, I need to buy a new subscription, thanks

Alun
Please log in to post in this forum.

Click here to login